Di Posting Oleh : Simple Learning
Kategori : MPLS
Prerequisites: CCNP level skills.
Note!
This topology layout is based on the new physical topology presented here.
Topology
Task 1
Using the physical topology presented here configure the IP addressing according to the following diagram. Make sure that all routers and switches can ping each other on a point-to-point basis (All loopbacks use 10.0.x.x/24 addresses where x=router number, sw1=7, sw2=8 etc.).
Pic. 1 - MPLS Topology Diagram.
Task 2
Once devices can ping each other on a point-to-point basis, enable OSPF on links between R1, R2, R3 and SW3 (core of our MPLS network) Advertise loopback addresses as /32 prefixes. Use AREA 0.
Solution
Task 1
Using the physical topology presented here configure the IP addressing according to the following diagram. Make sure that all routers and switches can ping each other on a point-to-point basis (All loopbacks use 10.0.x.x/24 addresses where x=router number, sw1=7, sw2=8 etc.).
!
interface Loopback0
ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.12
encapsulation dot1Q 12
ip address 172.16.12.1 255.255.255.0
!
interface FastEthernet0/0.13
encapsulation dot1Q 13
ip address 172.16.13.1 255.255.255.0
!
interface FastEthernet0/0.15
encapsulation dot1Q 15
ip address 172.16.15.1 255.255.255.0
!
interface FastEthernet0/0.16
encapsulation dot1Q 16
ip address 172.16.16.1 255.255.255.0
!
ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.12
encapsulation dot1Q 12
ip address 172.16.12.1 255.255.255.0
!
interface FastEthernet0/0.13
encapsulation dot1Q 13
ip address 172.16.13.1 255.255.255.0
!
interface FastEthernet0/0.15
encapsulation dot1Q 15
ip address 172.16.15.1 255.255.255.0
!
interface FastEthernet0/0.16
encapsulation dot1Q 16
ip address 172.16.16.1 255.255.255.0
!
R2 Configuration:
!
interface Loopback0
ip address 10.0.2.2 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.12
encapsulation dot1Q 12
ip address 172.16.12.2 255.255.255.0
!
interface FastEthernet0/0.13
encapsulation dot1Q 13
ip address 172.16.13.3 255.255.255.0
!
!
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 172.16.23.2 255.255.255.0
!
interface FastEthernet0/0.29
encapsulation dot1Q 29
ip address 172.16.29.2 255.255.255.0
!
ip address 10.0.2.2 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.12
encapsulation dot1Q 12
ip address 172.16.12.2 255.255.255.0
!
interface FastEthernet0/0.13
encapsulation dot1Q 13
ip address 172.16.13.3 255.255.255.0
!
!
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 172.16.23.2 255.255.255.0
!
interface FastEthernet0/0.29
encapsulation dot1Q 29
ip address 172.16.29.2 255.255.255.0
!
R3 Configuration:
!
interface Loopback0
ip address 10.0.3.3 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 172.16.23.3 255.255.255.0
!
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 172.16.34.3 255.255.255.0
!
interface FastEthernet0/0.103
encapsulation dot1Q 103
ip address 172.16.103.3 255.255.255.0
!
ip address 10.0.3.3 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 172.16.23.3 255.255.255.0
!
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 172.16.34.3 255.255.255.0
!
interface FastEthernet0/0.103
encapsulation dot1Q 103
ip address 172.16.103.3 255.255.255.0
!
R4 Configuration:
!
interface Loopback0
ip address 10.0.4.4 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 172.16.34.4 255.255.255.0
!
interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 172.16.45.4 255.255.255.0
!
ip address 10.0.4.4 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 172.16.34.4 255.255.255.0
!
interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 172.16.45.4 255.255.255.0
!
R5 Configuration:
!
interface Loopback0
ip address 10.0.5.5 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.15
encapsulation dot1Q 15
ip address 172.16.15.5 255.255.255.0
!
interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 172.16.45.5 255.255.255.0
!
ip address 10.0.5.5 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.15
encapsulation dot1Q 15
ip address 172.16.15.5 255.255.255.0
!
interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 172.16.45.5 255.255.255.0
!
R6 Configuration:
!
interface Loopback0
ip address 10.0.6.6 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.16
encapsulation dot1Q 16
ip address 172.16.16.6 255.255.255.0
!
ip address 10.0.6.6 255.255.255.0
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.16
encapsulation dot1Q 16
ip address 172.16.16.6 255.255.255.0
!
SW1 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.7.7 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/2
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/3
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/4
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/5
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/6
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/7
shutdown
!
interface FastEthernet1/8
shutdown
!
interface FastEthernet1/9
switchport mode trunk
!
interface FastEthernet1/10
shutdown
!
interface FastEthernet1/11
switchport mode trunk
!
interface FastEthernet1/12
shutdown
!
interface FastEthernet1/13
switchport mode trunk
!
interface FastEthernet1/14
shutdown
!
interface FastEthernet1/15
shutdown
!
interface Vlan1
no ip address
!
interface Vlan79
ip address 172.16.79.7 255.255.255.0
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.7.7 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/2
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/3
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/4
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/5
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/6
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/7
shutdown
!
interface FastEthernet1/8
shutdown
!
interface FastEthernet1/9
switchport mode trunk
!
interface FastEthernet1/10
shutdown
!
interface FastEthernet1/11
switchport mode trunk
!
interface FastEthernet1/12
shutdown
!
interface FastEthernet1/13
switchport mode trunk
!
interface FastEthernet1/14
shutdown
!
interface FastEthernet1/15
shutdown
!
interface Vlan1
no ip address
!
interface Vlan79
ip address 172.16.79.7 255.255.255.0
!
SW2 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.8.8 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
shutdown
!
interface FastEthernet1/1
shutdown
duplex full
speed 100
!
interface FastEthernet1/2
shutdown
duplex full
speed 100
!
interface FastEthernet1/3
shutdown
duplex full
speed 100
!
interface FastEthernet1/4
shutdown
duplex full
speed 100
!
interface FastEthernet1/5
shutdown
duplex full
speed 100
!
interface FastEthernet1/6
shutdown
duplex full
speed 100
!
interface FastEthernet1/7
switchport mode trunk
shutdown
!
interface FastEthernet1/8
switchport mode trunk
shutdown
!
interface FastEthernet1/9
switchport mode trunk
shutdown
!
interface FastEthernet1/10
switchport mode trunk
shutdown
!
interface FastEthernet1/11
switchport mode trunk
shutdown
!
interface FastEthernet1/12
switchport mode trunk
shutdown
!
interface FastEthernet1/13
switchport mode trunk
!
interface FastEthernet1/14
switchport mode trunk
shutdown
!
interface FastEthernet1/15
switchport mode trunk
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan89
ip address 172.16.89.8 255.255.255.0
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.8.8 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
shutdown
!
interface FastEthernet1/1
shutdown
duplex full
speed 100
!
interface FastEthernet1/2
shutdown
duplex full
speed 100
!
interface FastEthernet1/3
shutdown
duplex full
speed 100
!
interface FastEthernet1/4
shutdown
duplex full
speed 100
!
interface FastEthernet1/5
shutdown
duplex full
speed 100
!
interface FastEthernet1/6
shutdown
duplex full
speed 100
!
interface FastEthernet1/7
switchport mode trunk
shutdown
!
interface FastEthernet1/8
switchport mode trunk
shutdown
!
interface FastEthernet1/9
switchport mode trunk
shutdown
!
interface FastEthernet1/10
switchport mode trunk
shutdown
!
interface FastEthernet1/11
switchport mode trunk
shutdown
!
interface FastEthernet1/12
switchport mode trunk
shutdown
!
interface FastEthernet1/13
switchport mode trunk
!
interface FastEthernet1/14
switchport mode trunk
shutdown
!
interface FastEthernet1/15
switchport mode trunk
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan89
ip address 172.16.89.8 255.255.255.0
!
SW3 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.9.9 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
shutdown
duplex full
speed 100
!
interface FastEthernet1/1
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/2
shutdown
duplex full
speed 100
!
interface FastEthernet1/3
shutdown
duplex full
speed 100
!
interface FastEthernet1/4
shutdown
duplex full
speed 100
!
interface FastEthernet1/5
shutdown
duplex full
speed 100
!
interface FastEthernet1/6
shutdown
duplex full
speed 100
!
interface FastEthernet1/7
switchport mode trunk
shutdown
!
interface FastEthernet1/8
switchport mode trunk
shutdown
!
interface FastEthernet1/9
switchport mode trunk
!
interface FastEthernet1/10
switchport mode trunk
shutdown
!
interface FastEthernet1/11
switchport mode trunk
shutdown
!
interface FastEthernet1/12
switchport mode trunk
shutdown
!
interface FastEthernet1/13
switchport mode trunk
shutdown
!
interface FastEthernet1/14
switchport mode trunk
shutdown
!
interface FastEthernet1/15
switchport mode trunk
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan29
ip address 172.16.29.9 255.255.255.0
!
interface Vlan79
ip address 172.16.79.9 255.255.255.0
!
interface Vlan89
ip address 172.16.89.9 255.255.255.0
!
interface Vlan111
ip address 172.16.111.9 255.255.255.0
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.9.9 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
shutdown
duplex full
speed 100
!
interface FastEthernet1/1
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet1/2
shutdown
duplex full
speed 100
!
interface FastEthernet1/3
shutdown
duplex full
speed 100
!
interface FastEthernet1/4
shutdown
duplex full
speed 100
!
interface FastEthernet1/5
shutdown
duplex full
speed 100
!
interface FastEthernet1/6
shutdown
duplex full
speed 100
!
interface FastEthernet1/7
switchport mode trunk
shutdown
!
interface FastEthernet1/8
switchport mode trunk
shutdown
!
interface FastEthernet1/9
switchport mode trunk
!
interface FastEthernet1/10
switchport mode trunk
shutdown
!
interface FastEthernet1/11
switchport mode trunk
shutdown
!
interface FastEthernet1/12
switchport mode trunk
shutdown
!
interface FastEthernet1/13
switchport mode trunk
shutdown
!
interface FastEthernet1/14
switchport mode trunk
shutdown
!
interface FastEthernet1/15
switchport mode trunk
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan29
ip address 172.16.29.9 255.255.255.0
!
interface Vlan79
ip address 172.16.79.9 255.255.255.0
!
interface Vlan89
ip address 172.16.89.9 255.255.255.0
!
interface Vlan111
ip address 172.16.111.9 255.255.255.0
!
SW4 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.10.10 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
duplex full
speed 100
!
interface FastEthernet1/1
shutdown
duplex full
speed 100
!
interface FastEthernet1/2
shutdown
duplex full
speed 100
!
interface FastEthernet1/3
shutdown
duplex full
speed 100
!
interface FastEthernet1/4
shutdown
duplex full
speed 100
!
interface FastEthernet1/5
shutdown
duplex full
speed 100
!
interface FastEthernet1/6
shutdown
duplex full
speed 100
!
interface FastEthernet1/7
switchport mode trunk
shutdown
!
interface FastEthernet1/8
switchport mode trunk
shutdown
!
interface FastEthernet1/9
switchport mode trunk
shutdown
!
interface FastEthernet1/10
switchport mode trunk
shutdown
!
interface FastEthernet1/11
switchport mode trunk
!
interface FastEthernet1/12
switchport mode trunk
shutdown
!
interface FastEthernet1/13
switchport mode trunk
shutdown
!
interface FastEthernet1/14
switchport mode trunk
shutdown
!
interface FastEthernet1/15
switchport mode trunk
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan103
ip address 172.16.103.10 255.255.255.0
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.0.10.10 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
duplex full
speed 100
!
interface FastEthernet1/1
shutdown
duplex full
speed 100
!
interface FastEthernet1/2
shutdown
duplex full
speed 100
!
interface FastEthernet1/3
shutdown
duplex full
speed 100
!
interface FastEthernet1/4
shutdown
duplex full
speed 100
!
interface FastEthernet1/5
shutdown
duplex full
speed 100
!
interface FastEthernet1/6
shutdown
duplex full
speed 100
!
interface FastEthernet1/7
switchport mode trunk
shutdown
!
interface FastEthernet1/8
switchport mode trunk
shutdown
!
interface FastEthernet1/9
switchport mode trunk
shutdown
!
interface FastEthernet1/10
switchport mode trunk
shutdown
!
interface FastEthernet1/11
switchport mode trunk
!
interface FastEthernet1/12
switchport mode trunk
shutdown
!
interface FastEthernet1/13
switchport mode trunk
shutdown
!
interface FastEthernet1/14
switchport mode trunk
shutdown
!
interface FastEthernet1/15
switchport mode trunk
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan103
ip address 172.16.103.10 255.255.255.0
!
BB1 Configuration:
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.111
encapsulation dot1Q 111
ip address 172.16.111.254 255.255.255.0
!
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.111
encapsulation dot1Q 111
ip address 172.16.111.254 255.255.255.0
!
Task 2
Once devices can ping each other on a point-to-point basis, enable OSPF on links between R1, R2, R3 and SW3 (core of our MPLS network) Advertise loopback addresses as /32 prefixes. Use AREA 0.
R1 Configuration:
!
router ospf 1
log-adjacency-changes
network 10.0.1.1 0.0.0.0 area 0
network 172.16.12.1 0.0.0.0 area 0
network 172.16.13.1 0.0.0.0 area 0
log-adjacency-changes
network 10.0.1.1 0.0.0.0 area 0
network 172.16.12.1 0.0.0.0 area 0
network 172.16.13.1 0.0.0.0 area 0
!
R2 Configuration:
!
router ospf 1
log-adjacency-changes
network 10.0.2.2 0.0.0.0 area 0
network 172.16.12.2 0.0.0.0 area 0
network 172.16.23.2 0.0.0.0 area 0
network 172.16.29.2 0.0.0.0 area 0
log-adjacency-changes
network 10.0.2.2 0.0.0.0 area 0
network 172.16.12.2 0.0.0.0 area 0
network 172.16.23.2 0.0.0.0 area 0
network 172.16.29.2 0.0.0.0 area 0
!
R3 Configuration:
!
router ospf 1
log-adjacency-changes
network 10.0.3.3 0.0.0.0 area 0
network 172.16.23.3 0.0.0.0 area 0
network 172.16.13.3 0.0.0.0 area 0
!
log-adjacency-changes
network 10.0.3.3 0.0.0.0 area 0
network 172.16.23.3 0.0.0.0 area 0
network 172.16.13.3 0.0.0.0 area 0
!
SW3 Configuration:
!
router ospf 1
log-adjacency-changes
network 10.0.9.9 0.0.0.0 area 0
network 172.16.29.9 0.0.0.0 area 0
log-adjacency-changes
network 10.0.9.9 0.0.0.0 area 0
network 172.16.29.9 0.0.0.0 area 0
!
In my next lab we're going to create MPLS basic configuration.
Stay tuned!
0 Response to "Lab 168 - Creating MPLS Topology"
Post a Comment