Di Posting Oleh : Simple Learning
Kategori : IPv6
Prerequisites: CCNP level skills.
Topology
Notice!
In order to proceed to the next lab you must first complete all the previous labs (from lab 188 onwards).
Pic1. IPv6 Topology Diagram (so far).
Task 1
Document your IPv6 configuration by drawing a topology diagram (similar to mine above).
Task 2
Complete RIPng configuration using name 'CCIE' by enabling the protocol on R3's subinterface connecting it to R2. Be consistent with your current addressing scheme.
Task 3
Ensure R3 can reach all IPv6 networks advertised so far.
Solution
Task 2
Complete RIPng configuration using name 'CCIE' by enabling the protocol on R3's subinterface connecting it to R2. Be consistent with your current addressing scheme.
R1 Config:
!interface Serial0/0
ip address 172.16.123.1 255.255.255.0
encapsulation frame-relay
ipv6 address FE80::1 link-local
ipv6 address 2001:0:0:123::1/64
ipv6 rip CCIE enable
clock rate 2000000
frame-relay map ipv6 2001:0:0:123::3 102
frame-relay map ip 172.16.123.2 102 broadcast
frame-relay map ipv6 2001:0:0:123::2 102
frame-relay map ipv6 FE80::2 102 broadcast
no frame-relay inverse-arp
!
R2 Config:
!
interface Serial0/0
ip address 172.16.123.2 255.255.255.0
encapsulation frame-relay
ipv6 address FE80::2 link-local
ipv6 address 2001:0:0:123::2/64
ipv6 rip CCIE enable
clock rate 2000000
frame-relay map ipv6 2001:0:0:123::3 203
frame-relay map ipv6 FE80::3 203 broadcast
frame-relay map ip 172.16.123.3 203 broadcast
frame-relay map ip 172.16.123.2 201
frame-relay map ip 172.16.123.1 201 broadcast
frame-relay map ipv6 2001:0:0:123::1 201
frame-relay map ipv6 FE80::1 201 broadcast
no frame-relay inverse-arp
!
ipv6 router rip CCIE
no split-horizon
!
R3 Config:
!
ipv6 unicast-routing
!
interface Serial0/0.123 point-to-point
ip address 172.16.123.3 255.255.255.0
snmp trap link-status
ipv6 address FE80::3 link-local
ipv6 address 2001:0:0:123::3/64
ipv6 rip CCIE enable
frame-relay interface-dlci 302
!
Task 3
Ensure R3 can reach all IPv6 networks advertised so far.
Notice!
Since we have used IPv6 autoconfig and EUI-64 way of assigning addresses, you must use your own addresses in the below script. Also, if you use Dynamips/Dynagen/GNS3, every time you start the lab, IPv6 addresses will change which means that your script won't work again. You have to copy the CURRENT IPv6 addresses.
Verification on R3:
Here's tcl script:
foreach address {
2001:0:0:D0::FE
2001:2:2:0:1
2001:2:2:1::1
2001:2:2:2::1
2001:2:2:3::1
2001:0:0:D0::8
2001::D7:C007:16FF:FE14:0
2001::D7:C007:16FF:FE14:0
2001::D7:C004:16FF:FE05:1
2001::D7:C000:16FF:FE05:1
2001:0:0:123::1
2001:0:0:123::2
2001:0:0:123::3
2001::1B:C001:16FF:FE05:0
2001::1B:C006:16FF:FE14:0
} { ping $address }
Below, the script is pasted (issue 'tclsh' command + paste)
R3#tclsh
R3(tcl)#foreach address {
+>(tcl)#2001:0:0:D0::FE
+>(tcl)#2001:2:2:0:1
+>(tcl)#2001:2:2:1::1
+>(tcl)#2001:2:2:2::1
+>(tcl)#2001:2:2:3::1
+>(tcl)#2001:0:0:D0::8
+>(tcl)#2001::D7:C007:16FF:FE14:0
+>(tcl)#2001::D7:C007:16FF:FE14:0
+>(tcl)#2001::D7:C004:16FF:FE05:1
+>(tcl)#2001::D7:C000:16FF:FE05:1
+>(tcl)#2001:0:0:123::1
+>(tcl)#2001:0:0:123::2
+>(tcl)#2001:0:0:123::3
+>(tcl)#2001::1B:C001:16FF:FE05:0
+>(tcl)#2001::1B:C006:16FF:FE14:0
+>(tcl)#} { ping $address }
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:D0::FE, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/13/24 ms% Unrecognized host or address, or protocol not running.
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/28 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:3::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:D0::8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/20/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::D7:C007:16FF:FE14:0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/48 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::D7:C007:16FF:FE14:0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/14/20 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::D7:C004:16FF:FE05:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::D7:C000:16FF:FE05:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/5/12 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:123::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/8/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:123::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:123::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::1B:C001:16FF:FE05:0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::1B:C006:16FF:FE14:0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
R3(tcl)#tclquit
R3#
0 Response to "Lab 191 - RIPng on NBMA Links"
Post a Comment